8:12 PM CT: Clients should no longer receive errors when logging into Optimal Blue systems. Our teams will continue to monitor system performance. Please contact your Optimal Blue support team if you continue to experience issues accessing or navigating within Optimal Blue.
Posted Oct 29, 2025 - 20:12 CDT
Monitoring
3:52 PM CT: We are continuing to monitor the cloud provider issue with Microsoft Azure that is currently affecting businesses globally, including Optimal Blue. Microsoft has updated our team that they have started to deploy a fix for the problem across all nodes. Updates on this issue from Microsoft can be found on their Azure status page here: https://azure.status.microsoft/en-us/status. Until the issue is fully resolved, some users may still be experiencing intermittent access issues and performance degradation across some of our systems.
Posted Oct 29, 2025 - 15:54 CDT
Update
2:01 PM CT: We are continuing to monitor the cloud provider issue with Microsoft Azure that is currently affecting businesses globally, including Optimal Blue. As a result, some users may still be experiencing intermittent access issues and performance degradation across some of our systems. While we have not yet received a confirmed resolution or timeline for recovery, we are committed to keeping you informed and minimizing disruption to your experience.
Posted Oct 29, 2025 - 14:01 CDT
Investigating
Impacted Systems: All Optimal Blue Systems 11:25 AM CT: We are aware that there is a cloud provider issue with Microsoft Azure that is currently impacting businesses globally, including Optimal Blue. As a result, users may be experiencing intermittent access issues and performance degradation across some of our systems. The Optimal Blue Team is actively monitoring the situation and working closely with our Microsoft partners to resolve the issue as quickly as possible.
Posted Oct 29, 2025 - 11:26 CDT
This incident affected: Optimal Blue PPE, Optimal Blue Integrations & APIs, Optimal Blue Data & Analytic Tools, Optimal Blue Secondary Services, CompassEdge, and Loansifter.