Optimal Blue System Alert
Incident Report for Optimal Blue System
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 09:10 CDT
Investigating
All Optimal Blue team members are currently unable to make or receive phone calls. Please email your support team if you need assistance while we work to resolve this issue.
Posted Apr 12, 2024 - 07:55 CDT
This incident affected: Optimal Blue PPE.