Optimal Blue System Alert

Incident Report for Optimal Blue System

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 09:06 CST

Identified

4:57 PM CT: We are aware of an issue with Microsoft Exchange that has affected businesses across North America. As a result, users may have experienced intermittent issues with the delivery of emails to and from Optimal Blue. The Optimal Blue team has been actively monitoring the situation and working closely with our Microsoft partners, who have advised us that they have identified the issue and are working to remediate the issue as quickly as possible.
Posted Jan 22, 2026 - 16:57 CST

Investigating

2:56 PM CT: We are currently experiencing issues receiving external emails and are researching the cause of the delays/outage. If you need to contact Optimal Blue, you can reach us via phone. We will post an update as soon as we have additional information.
Posted Jan 22, 2026 - 14:56 CST
This incident affected: Optimal Blue PPE and Optimal Blue Secondary Services.