CompassPoint System Alert

Incident Report for Optimal Blue System

Resolved

The issue where some users were unable to access CompassPoint has been resolved.
Posted Aug 07, 2025 - 13:51 CDT

Investigating

Impacted Systems: CompassPoint
1:40 PM CT: The CompassPoint Team is aware of an issue where some users are unable to access CompassPoint. Our IT and Development Teams are working to identify and resolve the cause of this issue.
Posted Aug 07, 2025 - 13:41 CDT
This incident affected: CompassPoint.