2:05 PM CT: The issue causing new SMP SRP values to fail to load for some CompassEdge clients will be resolved with a release scheduled for tonight, July 21st, at 4:00 p.m. CT. While base prices are updating, SRP values will be stale until this update. Clients should continue to review best-ex before executing.
Posted Jul 21, 2026 - 14:05 CDT
Update
10:04 AM CT: Our teams continue to work to resolve this issue.
Posted Jul 21, 2026 - 10:05 CDT
Investigating
Impacted Systems: CompassEdge 8:15 AM CT: We are aware of an issue causing SMP Pricing to fail to load for some CompassEdge clients this morning due to an external change made to accommodate new pricing configurations in SMP. Our Product, Development, and Operations teams have identified the solution and will be implementing in the next hour. Please review timestamps for stale pricing, if running Best Ex this morning. We will send an all-clear shortly, when this issue is resolved and tested.