System Alert

Incident Report for Optimal Blue System

Resolved

This incident has been resolved.
Posted Jan 26, 2026 - 15:29 CST

Monitoring

2:24 pm CT: We have been advised by Freddie Mac that they have deployed the fix to resolve the issue with committing loans. Contracts are now being priced and committed successfully with Freddie Mac. Clients with loans still to commit should be able to do so in CompassEdge and Resitrader.
Posted Jan 26, 2026 - 14:24 CST

Investigating

Impacted Systems: CompassEdge, Resitrader
1:30 PM CT: We have confirmed with Freddie Mac that they are working on a fix to resolve an issue with committing loans. Our teams continue to stay engaged with our partners at Freddie Mac and are focused on resolving this issue as quickly as possible once Freddie Mac deploys their fix. Updates will posted here when we have additional information and when this issue is resolved.
Posted Jan 26, 2026 - 13:31 CST
This incident affected: CompassEdge and Resitrader.