Optimal Blue System Alert

Incident Report for Optimal Blue System

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 10:36 CDT

Monitoring

9:56 AM CT: The issue causing errors accessing and navigating within the Optimal Blue site has been resolved. Our teams will continue to monitor system performance.
Posted Mar 17, 2026 - 09:56 CDT

Investigating

Impacted Systems: Optimal Blue PPE
9:42 AM CT: The Optimal Blue Team is aware that some clients are experiencing errors accessing and navigating within the Optimal Blue site. Our Product, Development, and Operations teams are all focused on a resolution.
Posted Mar 17, 2026 - 09:42 CDT
This incident affected: Optimal Blue PPE.