Optimal Blue System Alert

Incident Report for Optimal Blue System

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 14:17 CDT

Monitoring

1:56 PM CT: The issue causing periods of intermittent system latency has been resolved. Our teams continue to monitor system performance.
Posted Apr 27, 2026 - 13:56 CDT

Investigating

Impacted Systems: Optimal Blue PPE
12:33 PM CT: The Optimal Blue Team is aware some clients are experiencing periods of intermittent system latency. The Optimal Blue Team is actively addressing the situation and working closely with our Microsoft partners to resolve the issue as quickly as possible.
Posted Apr 27, 2026 - 12:33 CDT
This incident affected: Optimal Blue PPE.